Fix for Sticking Accelerator Pedal at Zero Cost

This relates to a 2002 Buick LeSabre with a 3.8L engine, but the same general principles would apply to most any car with the same problem, I’d guess.

Occasionally, the accelerator would briefly resist moving when pressed. Then, when sufficient pressure was applied, it would break loose and operate normally. This seemed to be happening more frequently and the pressure required to break it loose became greater.

Time to look at it!

Step one was to remove the plastic shroud which covers the engine. This can easily be done by unscrewing the oil fill spout (the 3-inch extension onto which the oil filler cap fits) by unscrewing it a half turn and lifting it out. This exposed the fuel injector body and mechanism.

By manually working the sector pulley which was activated by the accelerator, I concluded that the butterfly was sticking in the closed position. But how to get at it was the problem!

I removed the rubber boot between the air box and the fuel injector body. But this revealed a “screen” which totally covered the intake!

That “screen” was held in by a “C” ring which I removed next. But the “screen” didn’t come out easily. It’s not a flat screen; it’s a honeycomb piece about 1/4 inch in thickness. It worked best to work it out a little all around the circumference and going around multiple times. I used a knife blade to pry it out, but next time I’d use a wire with a hook on the end to go in and pull it out from the inside.

    I think its purpose is two-fold:

  1. Create a laminar air flow into the chamber, and
  2. Serve as a “heat absorber” or flame suppressor in event of a backfire.

Once that was removed, I could see the butterfly and could pretty much confirm that was where the problem was. I cleaned it up around the circumference, but it still stuck. Then I squirted some AMSOIL MP (sort of like WD-40) into the butterfly shaft bushings.

That did the trick! No more sticking!

How long it will stay that way remains to be seen!

If it fails again, I’ll remove the throttle position sensor on the front of the injector body. That should expose one end of the butterfly shaft, and that was the end which gave the most trouble this time. (This requires a Torx wrench to remove.)

What was the cause? Truly, I don’t know. It acted like there was “old grease” in there which gummed up, but doubt that it was lubricated with grease. Maybe “sticky stuff” in the gasoline over 60k miles?

Copyright 2007 by Keith A. Williams



Source by Keith A. Williams

Phyllis Moloney